The AWS SDK for Ruby helps you to get started building applications using AWS infrastructure services, including Amazon S3, Amazon EC2, Amazon DynamoDB, and more.

Version 2 is the current version of the AWS SDK for Ruby. It is stable, fully supported, and recommended for use in production applications and features.

API Reference
Describes all the API operations for the SDK in detail. Also provides sample requests, responses, and errors for the supported AWS services.

AWS SDK for Ruby - Version 1 (Legacy)

Version 1 should not be used by new users or new applications. These links are only for developers who need to work with existing code that depends on version 1.

API Reference

Getting Started Guide

Developer Guide