Release: AWS SDK for Ruby 1.1.1

Release Notes>Ruby>Release: AWS SDK for Ruby 1.1.1
This release fixes issues reported on the AWS forums.

Details

Submitted By: Matty@AWS
Release Date: August 18, 2011 8:58 PM GMT
Latest Version: 1.1.1
Created On: August 18, 2011 8:58 PM GMT
Last Updated: August 18, 2011 8:58 PM GMT

Latest Version

Download the latest version of the AWS SDK for Ruby:

gem install aws-sdk

Resolved Issues

Change Description
Expiration time and conditions on presigned POST

Resolved an issue where setting a condition on a presigned POST overwrote the expiration time.

Trailing slashes in Amazon S3 object names

Resolved an issue where trailing slashes in Amazon S3 object names were handled improperly.

Supported API Versions

This release of the SDK supports the following API versions:

Service API Version
Amazon Elastic Compute Cloud 2011-02-28
Amazon SimpleDB 2009-04-15
Amazon Simple E-mail Service 2010-12-01
Amazon Simple Notifications Service 2010-03-31
Amazon Simple Queue Service 2009-02-01
Amazon Simple Storage Service 2006-03-01
AWS Identity and Access Management 2010-05-08
AWS Security Token Service 2011-06-15
©2014, Amazon Web Services, Inc. or its affiliates. All rights reserved.