如何解决 Amazon EMR 错误“The supplied bootstrap action(s):'Custom action' are not supported”?

上次更新时间:2019 年 6 月 20 日

我使用 Amazon EMR 4.x 或 5.x 发行版启动了集群。在运行引导操作时,我收到如下错误消息:

“The supplied bootstrap action(s):'Custom action' are not supported by release 'emr-4.x.x/5.x.x'.”

简短描述

当您尝试使用不再受支持的引导操作配置应用程序时,会发生此错误。Amazon EMR 发行版 4.0.0 及更高版本使用配置分类(而不是引导操作)来配置应用程序。

解决方法

Amazon EMR 4.x 和 5.x 发行版不支持以下引导操作。使用配置对象替换这些引导操作的功能。

  • configure-daemons
  • configure-hadoop
  • S3Get

有关哪些引导操作映射到 Amazon EMR 4.x 和 5.x 发行版中的哪个配置分类的列表,请参阅使用 Amazon EMR 的早期 AMI 版本自定义集群和应用程序配置


这篇文章对您有帮助吗?

您觉得我们哪些地方需要改进?


需要更多帮助?