Comment me préparer à la fin du support de Kubernetes 1.15 sur Amazon EKS ?

Dernière mise à jour : 29/04/2021

Je souhaite me préparer à la fin du support de Kubernetes 1.15 sur Amazon EKS dans Amazon Elastic Kubernetes Service (Amazon EKS).

Brève description

Kubernetes 1.15 sur Amazon EKS arrive en fin de support le 3 mai 2021.

Remarque : après la fin du support de Kubernetes 1.15 par la communauté Open Source le 6 mai 2020, AWS fournit une année supplémentaire de support de Kubernetes 1.15 sur Amazon EKS. Cela signifie qu'aucun correctif de bogue ou correctif de vulnérabilité de sécurité ne sera rétroporté vers Kubernetes 1.15 sur Amazon EKS. Pour plus d'informations, consultez les versions de correctifs Kubernetes sur le site Kubernetes GitHub.

Solution

Pour préparer la fin du support, procédez comme suit :

  1. Réalisez l'impact potentiel de cette fin de support.
  2. Complétez les prérequis à la mise à jour de Kubernetes 1.16.
  3. Mettez à jour vos clusters Amazon EKS d'ici le 3 mai 2021.

Pour plus d'informations sur la préparation à ce retrait, consultez la section Préparation aux retraits de l'API Kubernetes lors d'un passage de la version 1.15 à la version 1.16.

Remarque : si vous rencontrez des problèmes avec vos pods ou applications Amazon EKS, consultez la section Prérequis à la mise à jour de Kubernetes 1.16. Le problème le plus courant est l'échec du démarrage du pod kube-proxy parce que l'indicateur --resource-container se trouve toujours dans le DaemonSet du kube-proxy. Pour résoudre ce problème, supprimez l'indicateur --resource-container.


Cet article vous a-t-il été utile ?


Besoin d'aide pour une question technique ou de facturation ?