Inizia a usare AWS CDK

GUIDA ALLE OPERAZIONI DI BASE

Modulo 1: comprendere i requisiti di CDK

In questo modulo scoprirai i prerequisiti per eseguire CDK

Introduzione

È necessario aver installato e configurato alcuni prerequisiti per utilizzare CDK. In questa guida non ci addentreremo nei dettagli, ma è possibile fare riferimento a guide e documentazioni esistenti su come farlo.

Avrai modo di approfondire i seguenti aspetti

  • Configurare AWS CLI
  • Scegliere e installare un IDE
  • Assicurarsi di avere pronto il framework di linguaggio corretto

 Tempo richiesto per il completamento

5 minuti

 Prerequisiti del modulo

  • Account AWS con accesso da amministratore**
  • Browser consigliato: l'ultima versione di Chrome o Firefox

[**]Gli account creati nelle ultime 24 ore potrebbero non avere ancora accesso a tutti servizi richiesti per questo tutorial.

Prerequisiti

Interfaccia a riga di comando di AWS

Affinché AWS CDK possa interagire con il tuo account AWS, sono necessarie le credenziali e che AWS CLI sia installato e configurato. Se non l'hai ancora fatto, segui la guida Configura il tuo ambiente per configurare il CLI nella tua workstation.

Se utilizzerai AWS CDK su AWS Cloud9, il CLI dovrebbe già essere installato e configurato.

Disporre di un IDE

Uno dei vantaggi di AWS CDK è poter sfruttare il proprio ambiente di sviluppo preferito e avere un'esperienza ricca quando si esplorano le centinaia di diversi servizi e funzionalità di AWS.

Ti consigliamo caldamente di utilizzare un IDE che supporti il completamento del codice e l'evidenziazione della sintassi per il linguaggio che preferisci:

  • VSCode
  • AWS Cloud9
  • Atom
  • vim
  • emacs
  • WebStorm
  • PyCharm

Diversi framework di linguaggio

Node.js

AWS CDK utilizza versioni specifiche di AWS CDK Node.js (>=10.13.0, a eccezione della versione 13.0.0 - 13.6.0). Si consiglia una versione con long-term-support (LTS) attivo.

  • Per installare node.js, segui le istruzioni ufficiali sito Web di node.js quindi le istruzioni per il tuo sistema operativo.
  • Se hai già installato node.js, verifica quale versione è in esecuzione:
node --version

Python

Se scegli di utilizzare Python come linguaggio preferito di CDK, dovrai aver installato Python. In particolare, avrai bisogno di aver installato Python 3.6 o successivo. Puoi trovare informazioni sull'installazione di Python qui.

Inoltre, dovrai aver installato il Python Package Manager (pip). Qui puoi trovare le istruzioni per l'installazione.

.NET

Per il tuo sviluppo con .NET su CDK, dovrai aver installato .NET Core SDK. Nello specifico, avrai bisogno della versione 3.1 o successiva. Puoi trovare qui informazioni su come installare e scaricare .NET Core SDK.

Java

Se il tuo linguaggio preferito è Java, dovrai aver installato un JDK (kit di sviluppo Java). Avrai bisogno di JDK 8 o successivo. Qui puoi trovare informazioni su come scaricare e installare la distribuzione Amazon Coretto 8. Se non vuoi utilizzare Amazon Coretto, sono disponibili altre distribuzioni JDK 8.

Conclusione

Ora sei pronto a iniziare con il nuovo AWS CDK. Si consiglia di utilizzare AWS Cloud9 per questa guida dopo aver installato tutti i prerequisiti.

A seguire: Installare CDK CLI

Facci sapere com'è andata.

Grazie per il tuo feedback
Siamo contenti che questa pagina ti sia stata d’aiuto. Vuoi condividere ulteriori dettagli per aiutarci a continuare a migliorare?
Chiudi
Grazie per il tuo feedback
Ci dispiace che questa pagina non ti sia stata d'aiuto. Vuoi condividere ulteriori dettagli per aiutarci a continuare a migliorare?
Chiudi