Amazon EKS의 Kubernetes 1.15에 대한 지원 종료에 대비하려면 어떻게 해야 합니까?

최종 업데이트 날짜: 2021년 4월 29일

Amazon EKS(Amazon Elastic Kubernetes Service)에서 Amazon EKS의 Kubernetes 1.15에 대한 지원 종료에 대비하고 있습니다.

간략한 설명

Amazon EKS의 Kubernetes 1.15는 2021년 5월 3일에 지원이 종료됩니다.

참고: 2020년 5월 6일에 Kubernetes 1.15에 대한 오픈 소스 커뮤니티 지원이 종료된 후, AWS는 Amazon EKS의 Kubernetes 1.15에 대해 추가로 1년 지원을 제공했습니다. 이는 버그 수정 또는 보안 취약성 패치가 Amazon EKS의 Kubernetes 1.15로 백포팅되지 않음을 의미합니다. 자세한 내용은 Kubernetes GitHub 사이트의 Kubernetes 패치 릴리스를 참조하세요.

해결 방법

지원 종료에 대비하려면 다음 단계를 완료하세요.

  1. 지원 종료가 미치는 영향을 파악합니다.
  2. Kubernetes 1.16 업데이트 사전 조건을 충족합니다.
  3. 2021년 5월 3일까지 Amazon EKS 클러스터를 업데이트합니다.

사용 중단 대비에 대한 자세한 내용은 Preparing for Kubernetes API deprecations when going from 1.15 to 1.16을 참조하세요.

참고: Amazon EKS 포드 또는 앱에 문제가 있는 경우 Kubernetes 1.16 업데이트 사전 조건을 참조하세요. 가장 일반적인 문제는 --resource-container 플래그가kube-proxy DaemonSet에 남아 있기 때문에 kube-proxy가 시작되지 않는 것입니다. 이 문제를 해결하려면 --resource-container 플래그를 제거합니다.


이 문서가 도움이 되었나요?


결제 또는 기술 지원이 필요하세요?