Alex helps you change
the compatibility level on your
DB instance running RDS SQL Server

change-compatibility-sql-server-alex

My application is using a feature of SQL Server that is deprecated in newer versions, and I want to allow backward compatibility, or I’ve upgraded an instance or am restoring a backup taken from an older SQL version. How do I change my RDS SQL Server DB instance’s compatibility level?

If you use Microsoft SQL Server Management Studio to administer your database, the option to change the compatibility level of an RDS database running SQL Server is unavailable.

If you need to change the compatibility level of your database, instead use the ALTER DATABASE command. For example, you might use commands similar to the following:

ALTER DATABASE SET COMPATIBILITY_LEVEL = 120;

GO


Did this page help you? Yes | No

Back to the AWS Support Knowledge Center

Need help? Visit the AWS Support Center

Published: 2016-12-05