How do I resolve the Amazon EMR error "The supplied bootstrap action(s):'Custom action' are not supported"?

Last updated: 2019-06-20

I launched a cluster using an Amazon EMR 4.x or 5.x release version. When I run bootstrap actions, I get an error message like this:

"The supplied bootstrap action(s):'Custom action' are not supported by release 'emr-4.x.x/5.x.x'."

Short Description

This error happens when you try to configure your application using a bootstrap action that's no longer supported. Amazon EMR release versions 4.0.0 and later use configuration classifications to configure applications, instead of bootstrap actions.

Resolution

The following bootstrap actions are not supported in Amazon EMR 4.x and 5.x release versions. Use configuration objects to replace the functionality these bootstrap actions.

  • configure-daemons
  • configure-hadoop
  • S3Get

For a list of which bootstrap actions map to which configuration classifications in Amazon EMR 4.x and 5.x release versions, see Customizing Cluster and Application Configuration With Earlier AMI Versions of Amazon EMR.


Did this article help you?

Anything we could improve?


Need more help?