Amazon Aurora DB 인스턴스의 인스턴스 클래스를 변경하거나 조정할 때 오류가 발생하는 이유는 무엇인가요?

최종 업데이트 날짜: 2021년 1월 28일

Amazon Aurora DB 인스턴스가 있는데 인스턴스 클래스를 조정하고 싶습니다. 인스턴스 클래스를 변경할 수 없는 이유는 무엇이며 DB 인스턴스를 조정할 때 발생하는 오류를 어떻게 해결하나요?

간략한 설명

Amazon Aurora DB 인스턴스의 인스턴스 클래스를 변경할 때 다음 오류 중 하나가 나타날 수 있습니다.

  • “현재 인스턴스의 가용 영역에서 사용 가능한 요청된 클래스의 인스턴스가 없기 때문에 인스턴스 클래스를 수정할 수 없습니다. 나중에 다시 요청해 주세요.”
  • “DB 클러스터 <cluster>이(가) db.r4.large를 지원하려면 데이터베이스 엔진 업그레이드가 필요합니다.”
  • “RDS는 다음과 같은 조합으로 DB 인스턴스 생성을 지원하지 않습니다. DBInstanceClass=db.r5.8xlarge, Engine=aurora, EngineVersion=5.6.10a, LicenseModel=general-public-license”

오류를 해결하기 전에 DB 클러스터를 최신 엔진 버전에서 실행하거나 장기 지원(LTS) 버전을 사용하는 것이 좋습니다. 최신 엔진 버전에는 보안, 안정성 및 인스턴스 가용성 향상을 위한 수정 사항이 포함되어 있습니다.

  • DB 클러스터가 Amazon Relational Database Service(Amazon RDS) 콘솔에서 5.6.10a로 표시되는 버전에서 실행 중인 경우 1.22.3(권장 버전) 또는 1.19.6(LTS 버전)으로 테스트 및 업그레이드하는 것이 좋습니다.
  • DB 클러스터가 Amazon RDS 콘솔에서 5.7.12로 표시되는 버전에서 실행 중인 경우 2.07.3(권장 버전) 또는 2.04.9(LTS 버전)로 테스트 및 업그레이드하는 것이 좋습니다.
  • 이전 버전에서 업그레이드한 후에는 DB 클러스터의 인스턴스에 대한 OS 업그레이드를 수행해야 할 수도 있습니다. 계속하기 전에 이러한 업그레이드를 적용하세요.

참고: Aurora 복제 기능을 사용하여 데이터베이스 업그레이드를 생성 및 테스트할 수 있습니다. 또한 일부 리전 또는 가용 영역(AZ)에서는 T2 또는 R3과 같은 이전 인스턴스 클래스를 사용하지 못할 수 있습니다. T3 및 R5와 같은 최신 인스턴스 클래스를 사용하는 것이 가장 좋습니다.

해결 방법

현재 인스턴스의 가용 영역에서 사용 가능한 요청된 클래스의 인스턴스가 없기 때문에 인스턴스 클래스를 수정할 수 없습니다. 나중에 다시 요청해 주세요.

이는 Aurora DB 인스턴스의 인스턴스 클래스를 변경할 때 발생하는 가장 일반적인 오류 중 하나입니다. 이 오류의 원인은 2가지입니다.

  • AZ에 선택한 대상 인스턴스 클래스에 대한 용량이 없습니다. AZ에 대상 인스턴스 클래스에 필요한 온디맨드 용량이 충분하지 않으면 몇 분 정도 기다린 다음 인스턴스 클래스를 다시 수정해 보세요.

  • 대상 인스턴스 클래스가 AZ에서 지원되지 않습니다. 인스턴스가 실행 중인 AZ에서 Aurora 엔진 및 엔진 버전에 대해 대상 인스턴스 클래스가 지원되지 않을 때 이 오류가 발생합니다. 엔진, 엔진 버전 및 인스턴스 클래스를 지원하는 AZ를 확인하려면 다음 명령을 실행합니다.
aws rds describe-orderable-db-instance-options --engine <engine_name> --engine-version <engine_version> --db-instance-class <instance_class> --query 'OrderableDBInstanceOptions[].AvailabilityZones'
예:
aws rds describe-orderable-db-instance-options --engine aurora --engine-version 5.6.10a --db-instance-class db.t3.medium --query 'OrderableDBInstanceOptions[].AvailabilityZones'

DB 클러스터 <cluster>이(가) db.r4.large를 지원하려면 데이터베이스 엔진 업그레이드가 필요합니다.

이 오류는 드물지만 DB 클러스터가 이전 버전의 Aurora에서 실행 중인 경우 발생합니다. db.r4 인스턴스 패밀리는 Aurora 버전 1.14.4 이상에서만 지원됩니다. DB 클러스터의 정확한 엔진 버전을 찾으려면 클러스터에 로그인하고 다음 쿼리를 실행합니다.

SELECT @@AURORA_VERSION;

apply-pending-maintenance-actions CLI 명령을 실행하여 데이터베이스 엔진 업그레이드를 예약할 수 있습니다.

aws rds apply-pending-maintenance-action --resource-identifier arn:aws:rds:us-east-1:123456789012:cluster:aurora-cluster --apply-action system-update --opt-in-type immediate

RDS는 다음과 같은 조합으로 DB 인스턴스 생성을 지원하지 않습니다. DBInstanceClass=db.r5.8xlarge, Engine=aurora, EngineVersion=5.6.10a, LicenseModel=general-public-license

이전 버전의 Aurora를 실행하는 경우 이 오류가 발생합니다. db.r5 인스턴스 패밀리는 일부 Aurora 버전에서 지원되지 않습니다. 예를 들어, db.r5.8xlarge 인스턴스 클래스는 Aurora 버전 1.19.6 이상이어야 Aurora MySQL 5.6 클러스터에 대해 지원됩니다. 클러스터에서 이전 버전을 실행 중인 경우 이 인스턴스 클래스를 변경하려고 하면 이 오류가 나타납니다.

다음과 유사한 CLI 명령을 실행하여 엔진 및 인스턴스 클래스 조합에 대해 지원되는 엔진 버전을 찾습니다.

aws rds describe-orderable-db-instance-options --engine aurora --db-instance-class db.r5.8xlarge --query 'OrderableDBInstanceOptions[].EngineVersion'

이 문서가 도움이 되었나요?


결제 또는 기술 지원이 필요합니까?