AWS Database Blog
Using StatsD for monitoring Oracle databases running on Amazon RDS or Amazon EC2
Monitoring databases is essential in large IT environments to prevent potential issues from becoming major problems that can result in data loss or downtime. Having custom dashboards and alarm-based monitoring for the database can help in analyzing historical metrics patterns and improve database availability by alerting users of any abnormal threshold breaches. In this post, we show you how to set up monitoring for your Oracle database using StatsD.
Automatic reconnection to Amazon RDS for Oracle read replicas during disaster recovery
Amazon RDS for Oracle offers ease of operability, maintenance, scalability, and reliability while migrating Oracle workloads to AWS. The read replica in Amazon RDS for Oracle is a physical copy of the primary database that can be set up either in mounted or read-only mode. In mounted mode, the replica instance isn’t open for read operations, however in read-only mode, it allows read operations on the replica instance. During managed Oracle Data Guard Switchover with Oracle RDS for Oracle, the database role reversal takes place between the RDS for Oracle primary database and its replica. Similarly, in case of a disaster, you can promote the read replica to a standalone instance. In both scenarios, the application needs to point to the endpoint of the new primary database to establish connectivity. In this post, we provide guidance to configure the automatic reconnection of the application to a standby database during a disaster recovery incident while using replication with Oracle Data Guard using Oracle services and a TNS names connection alias.
Set up Database Resource Manager in Amazon RDS for Oracle
After migrating your Oracle databases to Amazon RDS for Oracle, you might want to exercise more control over CPU and other resources. For such use cases you can use Oracle Resource Database Manager to prioritize the CPU allocation for certain applications or users in order to have consistent performance for highly critical applications. This feature was introduced In Oracle 8i and is available in all subsequent versions of Oracle Enterprise Edition. In this post, we show how to implement Oracle Database Resource Manager in an RDS for Oracle database using the CPU utilization attribute. These criteria can be used to distribute and limit the resources across high-priority web-based OLTP transactions and low-priority batch processing.
Configure reverse replication using AWS DMS to migrate an Oracle database to Amazon RDS for Oracle
When migrating your database to the cloud, you should prepare a failback plan (or recovery plan) if the migration fails. To provide failback functionality, AWS Database Migration Service (AWS DMS) supports reverse replication, which you can use as a minimal downtime failback strategy while migrating from Oracle on premises to Amazon Relational Database Service (Amazon […]



