AWS Database Blog
Enforcing TLS and managing certificate rotation for RDS and Amazon Aurora PostgreSQL
When an Amazon RDS or Amazon Aurora PostgreSQL certificate expires and client trust stores aren’t updated, connections fail without warning. This post shows how to enforce TLS for all PostgreSQL connections, configure client-side certificate verification, and deploy automated monitoring that alerts you before certificate rotation events.
Optimize Amazon RDS performance with io2 Block Express storage for production workloads
Choosing the right storage configuration that meets performance requirements is a common challenge when creating and managing database instances. In this post, we provide an end-to-end guide for what storage class to choose depending on your use case. In addition, we compare the performance of different storage volumes on open source engines supported by Amazon RDS, to validate them from a database-centric perspective.

