Publicado: Jun 19, 2019

Agora o Amazon Elastic Kubernetes Service (EKS) oferece suporte ao Kubernetes versão 1.13.7 para todos os clusters. Além disso, você pode usar o ECR PrivateLink e o Kubernetes PodSecurityPolicies com seus clusters do EKS.

O Kubernetes está evoluindo rapidamente, com lançamentos de recursos e correções de bugs frequentes. O Kubernetes versão 1.13 permite usar o ECR PrivateLink para puxar imagens com segurança para executar seus aplicativos e permite ativar o Kubernetes Pod Security Policies para validar solicitações de criação e atualização de pod em um conjunto de regras. Destaques adicionais da versão incluem o lançamento beta do Kubernetes DryRun, do TaintBasedEvictions e do suporte ao Raw Block Volume. Saiba mais sobre o Kubernetes versão 1.13 nas notas de release do projeto do Kubernetes.

Saiba mais sobre as versões do Kubernetes disponíveis para cargas de trabalho de produção no Amazon EKS e como atualizar seu cluster para a versão 1.13 na documentação do EKS.

Saiba como configurar políticas de segurança de pod com seu cluster do Amazon EKS em nosso blog

Uma nota sobre a substituição da versão 1.10 do Kubernetes

O suporte do Amazon EKS é um espelho do suporte da comunidade do Kubernetes e oferece suporte às três versões mais recentes. O Kubernetes 1.10, 1.11, 1.12 e 1.13 contam hoje com suporte integral e é possível iniciar novos clusters usando qualquer uma dessa versões. No entanto, é importante que cada cliente considere a atualização para as versões mais recentes.

Recomendamos que os clientes atualizem os clusters 1.10 ou 1.11 existentes e os nós de trabalho para a versão 1.12 ou 1.13 assim que possível. Saiba mais sobre as políticas de ciclo de vida da versão do EKS na documentação.