AWS Developer Blog

Ruby 1.8 End of Life Plan

by Trevor Rowe | on | in Ruby | Permalink | Comments |  Share

You have probably heard that Ruby 1.8.7 has officially reached it’s end of life. This makes it important for us to discuss what our plans will be for the AWS SDK for Ruby (aws-sdk gem) with regards to Ruby 1.8.

We currently support as far back as Ruby 1.8.7. There are now additional considerations with the passing of the end of life date. We would love to hear your feedback. There is an issue on our GitHub project where the discussion has already started. Please join in and share your input!