Amazon ECS 관리형 대몬, 이제 중요하지 않은 대몬 지원

게시된 날짜: 2026년 9월 3일

Amazon Elastic Container Service(Amazon ECS)가 이제 ECS 관리형 인스턴스에 대해 중요하지 않은 관리형 대몬을 지원합니다. 대몬을 중요하지 않은 대몬으로 구성하면 대몬에 오류가 발생하거나, 중지되거나, 비정상 상태가 되더라도 미션 크리티컬 애플리케이션 태스크는 중단 없이 계속 실행됩니다.

Amazon ECS 관리형 대몬을 사용하면 애플리케이션 배포와 관계없이 소프트웨어 에이전트를 중앙에서 배포하고 관리할 수 있으므로 컨테이너 인프라 전반에 걸쳐 일관된 적용 범위와 규정 준수를 보장할 수 있습니다. 일부 미션 크리티컬 애플리케이션의 경우, 애플리케이션 태스크의 중단 없는 실행이 로깅이나 지표 수집처럼 보조적인 대몬 기능보다 중요할 수 있습니다. 이번 출시를 통해 이제 관리형 대몬을 중요하지 않음으로 구성하여, 대몬에 장애가 발생하더라도 애플리케이션 태스크가 반복적으로 중단되고 다시 시작되는 현상이 발생하지 않도록 할 수 있습니다. 중요하지 않은 대몬 태스크가 실패하거나 중지되거나 비정상 상태가 되더라도 컨테이너 인스턴스는 활성 상태를 유지하고 기존 애플리케이션 태스크는 중단 없이 계속 실행되며, ECS는 새 애플리케이션 태스크를 해당 인스턴스에 계속 배치하고 인스턴스 등록도 차단하지 않습니다. 따라서 대몬이 시작되지 않더라도 태스크가 즉시 시작됩니다. Amazon ECS는 대몬 태스크가 시작되지 않을 때 EventBridge 이벤트를 전송하고, 중요한 대몬과 중요하지 않은 대몬 모두에 대한 서비스 작업 로그를 기록하여 대몬 상태에 대한 완벽한 관찰성을 제공합니다.

시작하려면 AWS Console, CLI, CloudFormation 또는 AWS SDK를 사용하여 대몬을 생성하거나 업데이트할 때 critical 파라미터를 false로 설정하여 중요하지 않은 대몬을 생성할 수 있습니다. 중요하지 않은 대몬은 Amazon ECS 관리형 대몬이 지원되는 모든 AWS 리전에서 사용할 수 있습니다. 자세한 내용은 설명서 페이지에서 확인하세요.