AWS Developer Blog

AWS SDK for .NET version 1 has reached the end of support

AWS SDK for .NET version 1 (v1) has reached the end of support. We will no longer publish any updates to .NET SDK v1, including critical bugs or security updates. Previously published releases will continue to be available via NuGet. The code will remain on GitHub, but the repository may be archived in the future. You man continue using .NET SDK v1 at your discretion.

If you are running applications using .NET SDK v1, we recommend that you migrate your applications to the latest major version – AWS SDK for .NET version 3 (v3). Please note that v3 includes breaking changes from v1, for detailed migration instructions please see our Migration Guide. The latest release of .NET SDK v3, version 3.7, transitions support for all non-Framework versions of the SDK to .NET Standard 2.0 and removes support for .NET Standard 1.3. For additional migration instructions please see our “Migrating to version 3.7 of the AWS SDK for .NET” guide.