게시된 날짜: Jun 19, 2019

Amazon Elastic Kubernetes Service(EKS)는 이제 모든 클러스터에 대해 Kubernetes 버전 1.13.7을 지원합니다. 또한, EKS 클러스터에서 ECR PrivateLink 및 Kubernetes PodSecurityPolicies를 사용할 수 있습니다.

Kubernetes는 빈번한 기능 릴리스 및 버그 수정을 통해 빠르게 발전하고 있습니다. Kubernetes 버전 1.13에서는 ECR PrivateLink를 사용하여 이미지를 안전하게 가져와서 애플리케이션을 실행하고, Kubernetes 팟 보안 정책을 활성화하여 일련의 규칙에 따라 팟 생성 및 업데이트 요청을 검증할 수 있습니다. 그 외 버전 하이라이트로는 Kubernetes DryRun, TaintBasedEvictions, Raw Block Volume 지원의 베타 출시가 포함됩니다. Kubernetes 버전 1.13에 대한 자세한 내용은 Kubernetes 프로젝트 출시 정보를 확인하십시오.

Amazon EKS의 프로덕션 워크로드에 사용 가능한 Kubernetes 버전을 확인하고 클러스터를 버전 1.3으로 업데이트하는 방법을 알아보려면 EKS 설명서를 참조하십시오.

Amazon EKS 클러스터에 팟 보안 정책을 구성하는 방법은 블로그에서 확인할 수 있습니다. 

Kubernetes 버전 1.10 사용 중단에 대한 참고 사항

Amazon EKS 지원에서는 Kubernetes 커뮤니티를 반영하여 가장 최근에 릴리스된 3개 버전을 완벽하게 지원합니다. 현재 Kubernetes 1.10, 1.11, 1.12 및 1.13이 모두 지원되며, 이러한 릴리스 중 하나를 사용해 새로운 클러스터를 시작할 수 있습니다. 그러나 각 고객은 가장 최신 릴리스로 전환하는 것을 고려하는 것이 중요합니다.

기존 1.10 또는 1.11 클러스터 및 작업자 노드를 가능한 한 빨리 1.12 또는 1.13으로 업그레이드하는 것이 좋습니다. EKS 버전 수명 주기 정책에 대한 자세한 내용은 설명서를 참조하십시오.