게시된 날짜: Sep 4, 2019

Amazon Elastic Kubernetes Service(EKS)는 이제 모든 클러스터에 대해 Kubernetes 버전 1.14.6을 지원합니다.

Kubernetes는 기능 릴리스 및 버그 수정을 자주 제공하며 빠르게 개선되고 있습니다. Kubernetes 버전 1.14 하이라이트에는 Durable Local Storage ManagementPod Priority에 대한 안정적인 지원과 Pid Limiting의 베타 버전이 포함되어 있습니다. Kubernetes 프로젝트 출시 정보에서 Kubernetes 버전 1.14에 대해 자세히 알아보십시오.

Amazon EKS의 프로덕션 워크로드에 사용 가능한 Kubernetes 버전을 확인하고 클러스터를 버전 1.14로 업데이트하는 방법을 알아보려면 EKS 설명서를 참조하십시오.

Windows 지원 참고 사항:

Kubernetes 1.14를 통해 Windows 노드를 더 안정적으로 지원할 수 있게 되었습니다. EKS에서는 현재 Windows 노드 및 컨테이너를 공개 평가판의 일부로 실행할 수 있도록 지원합니다. 공식 지원은 예정된 업데이트와 함께 제공될 예정입니다.

Kubernetes 버전 1.11 사용 중단에 대한 참고 사항:

Amazon EKS 지원은 가장 최근에 출시된 3개 버전에 대해 모든 지원을 제공함으로써 Kubernetes 커뮤니티를 미러링합니다. 현재 Kubernetes 1.11, 1.12, 1.13 및 1.14가 완전히 지원되며, 이러한 출시를 통해 새로운 클러스터를 시작할 수 있습니다. 하지만 Kubernetes의 분기별 릴리스 주기를 감안하면 모든 고객은 지속적인 업그레이드 계획을 유지하고 있어야 합니다.

Kubernetes 버전 1.11은 오늘부터 EKS에서 사용이 중단되며 2019년 11월 4일부터는 더 이상 지원되지 않을 예정입니다. 이날부터는 새 1.11 클러스터를 더 이상 생성할 수 없으며, Kubernetes 버전 1.11을 실행하는 모든 EKS 클러스터는 가장 최근에 출시된 플랫폼 버전인 Kubernetes 버전 1.12로 업데이트됩니다.

고객은 기존 1.11 또는 1.12 클러스터 및 작업자 노드를 가능한 한 빨리 1.13 이상으로 업그레이드하는 것이 좋습니다. EKS 버전 수명 주기 정책에 대한 자세한 내용은 설명서를 참조하십시오.