Release: AWS SDK for Ruby 1.6.5

Release Notes>Release: AWS SDK for Ruby 1.6.5
This release adds support to AWS::ELB for VPC attributes and resolves a few issues.

Details

Submitted By: trevor@AWS
Latest Version: 1.6.5
Created On: September 5, 2012 6:17 AM GMT
Last Updated: September 5, 2012 6:17 AM GMT

Latest Version

Download the latest version of the AWS SDK for Ruby:

gem install aws-sdk

New Features

Change Description
AWS::ELB

Added VPC attributes to AWS::ELB::LoadBalancer and AWS::ELB::LoadBalancerCollection#create.

Resolved Issues

Change Description
AWS::EC2::SecurityGroup::IpPermission

Fix issue breaking enumerable#include?, now sorting objects prior to comparison. AWS::EC2::SecurityGroup is also now sortable.

AWS::EC2::KeyPairCollection#create

#create now returns an AWS::EC2::KeyPair object with the proper configuration object.

AWS::S3Object

Added a require 'bate64' statement to this class.

Supported API Versions

This release of the SDK supports the following API versions:

Service API Version
Amazon CloudWatch 2010-08-01
Amazon DynamoDB 2011-12-05
Amazon Elastic Compute Cloud 2012-07-20
Amazon Elastic MapReduce 2009-03-31
Amazon Route 53 2012-02-29
Amazon Simple E-mail Service 2010-12-01
Amazon Simple Notifications Service 2010-03-31
Amazon Simple Queue Service 2011-10-01
Amazon Simple Storage Service 2006-03-01
Amazon Simple Workflow Service 2012-01-25
Amazon SimpleDB 2009-04-15
Auto Scaling 2011-01-01
AWS CloudFormation 2010-05-15
AWS Identity and Access Management 2010-05-08
AWS Security Token Service 2011-06-15
Elastic Load Balancing 2012-06-01
©2014, Amazon Web Services, Inc. or its affiliates. All rights reserved.