发布于: May 18, 2021

Kubernetes 目前的演进非常迅速,功能发布及漏洞修复工作开展得十分频繁。Kubernetes 1.20 版本的亮点包括:RuntimeClassProcess ID Limits 正日趋稳定, API Priority and Fairness 已默认启用,而 kubectl 调试正朝着测试阶段迈进。有关 Kubernetes 1.20 版本的更多信息,请参阅 Kubernetes 项目发行说明。 

要详细了解 Amazon Elastic Kubernetes Service (EKS) 上可用于生产工作负载的 Kubernetes 版本,以及如何将集群更新到 1.20 版本,请参阅 EKS 文档。Kubernetes 1.20 的 Amazon EKS Distro 版本通过 ECR 公有库GitHub 提供。

关于 Kubernetes 1.16 版本支持的说明:

Amazon EKS 可在任何给定时间至少支持 4 个 Kubernetes 版本。现在,Kubernetes 1.16、1.17、1.18、1.19 和 1.20 均已得到 EKS 全面支持,您可以使用这些版本中的任何一个启动新的集群。但是,考虑到 Kubernetes 的季度发布周期,所有客户都必须具有持续升级计划。

从 2021 年 7 月 15 日起,Kubernetes 1.16 版本不再受支持。届时,您将无法再创建新的 1.16 版集群,并且运行 Kubernetes 1.16 版的所有现有 EKS 集群将最终更新为 Kubernetes 1.17 版的最新可用平台版本。

我们建议客户尽快将现有 1.16 版集群和工作节点至少升级到 1.17 版。在文档中了解有关 EKS 版本生命周期策略的更多信息。