Publié le: Mar 28, 2019

Amazon Elastic Container Service for Kubernetes (EKS) prend désormais en charge Kubernetes version 1.12.6 pour tous les clusters. De plus, vous pouvez maintenant mettre à jour la version de votre cluster Amazon EKS à l'aide d’AWS CloudFormation.

Kubernetes évolue rapidement, et des nouvelles fonctionnalités et des correctifs de bugs y sont fréquemment ajoutés. Kubernetes version 1.12 apporte un certain nombre d’améliorations incrémentielles, notamment des stratégies de réseau de sortie, des performances améliorées pour HPA (Horizontal Pod Autoscaler), ainsi que plusieurs améliorations en matière d’allocation et de gestion des pods.

Amazon EKS prend désormais en charge la version 1.12.6 de Kubernetes pour les clusters et la version 1.12.7 pour les AMI optimisées EKS. Vous pouvez créer de nouveaux clusters à l'aide de la version 1.12 ou mettre à jour des clusters existants. En plus de prendre en charge les mises à jour de version de cluster via la console EKS, l'API ou la CLI, vous pouvez désormais utiliser CloudFormation pour mettre à jour la version de votre cluster en spécifiant une nouvelle version de Kubernetes dans le modèle CloudFormation de votre cluster.

Pour en savoir plus sur les versions de Kubernetes disponibles pour les charges de travail de production sur Amazon EKS et sur la migration de nouvelles versions de cluster, consultez la documentation EKS.

En savoir plus sur la version 1.12 de Kubernetes dans les notes de version du projet Kubernetes.

Une note sur la fin de vie de la version Kubernetes
Parallèlement au lancement de la version 1.12, nous annonçons notre politique de fin de vie. La prise en charge Amazon EKS reflète la communauté Kubernetes en fournissant une prise en charge complète des 3 versions les plus récentes. Kubernetes 1.10, 1.11 et 1.12 sont tous entièrement pris en charge aujourd'hui, et de nouveaux clusters peuvent être démarrés à l'aide de ces versions. Cependant, il est important que chaque client envisage de passer aux versions les plus récentes.

Nous recommandons aux clients d'utiliser l'API EKS updateClusterVersion pour mettre à niveau les clusters 1.10 existants vers 1.11 ou 1.12 dès que possible.