Sign in
Categories
Your Saved List Partners Sell in AWS Marketplace Amazon Web Services Home Help

Broken distro - cannot enable fips-updates

  • By AWS Customer
  • on 03/11/2022

This AMI is broken, as one cannot enable fips-updates. Two problems, one solvable by using apt-key to add a missing repo key, but "ua enable fips-updates" still fails:

The following packages have unmet dependencies:
ubuntu-aws-fips : Depends: libgcrypt20 (>= 1.8.5-5ubuntu1.fips.1.4) but 1.8.5-5ubuntu1.fips.1.1 is to be installed
Depends: libgcrypt20-hmac (>= 1.8.5-5ubuntu1.fips.1.4) but 1.8.5-5ubuntu1.fips.1.1 is to be installed

The Ubuntu Pro FIPS 18.04 AMI works fine.


  • By Carlos
  • on 06/08/2022

This issue has been solved in the latest ua versions. Now it is possible move from fips to fips-updates with no issues.