AWS Developer Tools Blog

Announcing the end of support for Ruby runtimes 1.9, 2.0, 2.1 and 2.2 for the AWS SDK For Ruby

Starting September 1, 2021, AWS SDK For Ruby will no longer support these end of life (EOL) Ruby runtime versions:

  • Ruby 1.9.3 – EOL began on 2015-02-23
  • Ruby 2.0.0 – EOL began on 2016-02-24
  • Ruby 2.1 – EOL began on 2017-03-31
  • Ruby 2.2 – EOL began on 2018-03-31

Since these versions have long passed end-of-life, we have seen support drop within the Ruby community, including Rake, Bundler, and some of our SDK dependencies. To make sure we’re providing up-to-date and secure libraries, we’re joining this migration. We encourage you to upgrade to Ruby 2.3 or later to ensure your applications and services remain secure.

Customers using bundler with these Ruby versions will not be broken and will not download newly released gem versions.

The provided in each service gem will specify the exact version where support for these runtime versions have been dropped. Customers using Ruby versions that will no longer be supported will have a warning printed out on the last supported version of each service gem.

Please see the Ruby maintenance branches webpage for a complete list of Ruby versions and their maintenance status. For more information regarding maintenance and deprecations for AWS SDK For Ruby, please see the AWS SDKs and Tools Maintenance Policy.